Our Team
Meet the Minds Behind GigaLinked
A dedicated team of experts working together to provide you with the best hosting experience.
Management Team

Kerem Aydin
Founder & Operations Management
Hi, I'm the driving force behind the growth and success of our business. I oversee all sales operations, ensuring we connect with the right clients and build lasting partnerships.
class NetworkManager { constructor() { this.nodes = []; this.connections = new Map(); } }
async function deployServer() { await initialize(); await configure(); return await start(); }

Conor Murphy
Founder & Backend Engineer
Hi, I'm the guy behind all the server work. I set up, manage, and maintain our network to ensure everything runs smoothly and efficiently.
GigaLinked Team
ping gigalinked.com -t
traceroute 1.1.1.1
show ip interface brief
const status = checkNetworkLatency();
if (status === 'optimal') { log.info('Network OK'); }
function monitorBandwidth() { /* ... */ }
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
router bgp 65000
neighbor 10.0.0.1 remote-as 65001
network 203.0.113.0 mask 255.255.255.0
Tsvetan Ivanov
Network Engineer
ABOUT
Hello, I am Tsvetan and I am responsible for the uptime of GigaLinked systems. If you're having any downtime or issues with our service reach out to me and I will handle it.
CONTACT
United Kingdom
Contract_Alpha.pdf
Old_Policy_v1.doc
Onboarding_Forms.zip
Performance_Review.xlsx
Callum William
HR Director
ABOUT
Hi, I oversee the sales team and ensure we meet our goals. My role is to manage client relationships, guide the team, and develop strategies to help grow our business.
CONTACT
United Kingdom
interface GigabitEthernet0/0 ip address 192.168.1.1 255.255.255.0 no shutdown
router bgp 65000 neighbor 10.0.0.1 remote-as 65001 network 203.0.113.0 mask 255.255.255.0

Tsvetan Ivanov
Network Engineer
Hello, I am Tsvetan and I am responsible for the uptime of GigaLinked systems. If you're having any downtime or issues with our service reach out to me and I will handle it.

Callum William
HR Director
Hi, I oversee the sales team and ensure we meet our goals. My role is to manage client relationships, guide the team, and develop strategies to help grow our business.